Welcome to Junk Jack Forum!  

• We need your support! 


Want to play with me?

Our Minecraft forum! Feel free to discuss Notch's creation here
  • Author
  • Message

Zero1000

Offline

User avatar
  • Posts: 2052
  • Joined: Sat Oct 27, 2012 2:33 am
  • Location: Being myself

Want to play with me?

PostTue Apr 01, 2014 8:37 pm

My ip is still not here.
You can play with me at 1.5.2 or 1.7.2, but they have some requeriments

1.5.2 requeriments
Open Spoiler
Arsmagica mod
TuxWeapons mod
Buildcraft mod
(Optional)Rei minimap
Good spanish if i don't understand some english words


1.7.2 don't needs mods, but you will not get mod weapons, they are great.

Pm me if you accept
My mc is in spanish
Image
Former Mercenary in The Hitlist
I leave as many griefers as my name! Zero, A member of ANARCHY
«A Nice Member in Apple FanClub»
Zero1000 is a Merchant of Many
Image

Return to Minecraft

Who is online

Users browsing this forum: No registered users and 2 guests

cron