Page 1 of 1

Multiplayer Freezes

PostPosted: Thu May 26, 2016 12:21 am
by WhiteFang
Every time I try connecting to my friends server using direct connect, my game freezes, then goes back to the multiplayer screen.

EDIT: is there a port I have to forward or what?

Re: Multiplayer Freezes

PostPosted: Fri May 27, 2016 8:18 pm
by Multipackwolf
Your friend needs to port forward the port 12345 (trust me, it's legit)

Re: Multiplayer Freezes

PostPosted: Fri May 27, 2016 9:32 pm
by Dunn17
Multipackwolf wrote:Your friend needs to port forward the port 12345 (trust me, it's legit)

You know how to forward ports? Mind helping me with an xbox one? :asd:

Re: Multiplayer Freezes

PostPosted: Fri May 27, 2016 9:57 pm
by Multipackwolf
I can forward ports.. But just don't ask for a walkthrough because every router model is different woth how they handle it. You'd do better looking at a guide for your specific router

Re: Multiplayer Freezes

PostPosted: Sat May 28, 2016 1:19 am
by WhiteFang
Multipackwolf wrote:I can forward ports.. But just don't ask for a walkthrough because every router model is different woth how they handle it. You'd do better looking at a guide for your specific router


Thank you so much.
Also, I can try to help for port forwarding in a different thread.

EDIT: Never mind. Port forwarding did NOT solve the issue. It still freezes the game for a brief second, then returns back to the multiplayer menu. Help!

Re: Multiplayer Freezes

PostPosted: Sat May 28, 2016 2:28 pm
by SollyStartles
Use steam.

Re: Multiplayer Freezes

PostPosted: Sat May 28, 2016 2:47 pm
by WhiteFang
SollyStartles wrote:Use steam.


We were both using my Steam account so starting it up didn't allow the other player to see it.

EDIT: I figured it out. Somewhat. I completely forgot about localhost (or 127.0.0.1) and that seemed to connect. However, upon joining the world, the host game freezes at sending world (0%)

EDIT2: Never mind, using the loopback address only works on the same PC. Otherwise, using none of the IP address (one given by game, my actual public IP, and loopback) work. Me hosting it, he can't connect (I'm port-forwarded, firewall off, etc) I've tried every setting, just doesn't seem to work.

EDIT3: Apparently retrying my actual IP works. The IP the game gives you does NOT work.